Back to Community
Zipline Installation Help

Hi All, about to pull my hair out here.

I am trying to install zipline on my windows 10 machine using Anaconda/Conda. Downloaded the latest Anaconda ... created an environment using python 3.5 (what zipline needs).

Then downloaded zipline, everything seemed to work fine.

When I go back to open a Jupyter Notebook under my new environment, Im asked to install which I do. This changes my environment from 3.5-->3.7 so zipline doesnt work!

How do I open a Jupyter notebook in using Python 3.5 so I can use zipline?

Thank you so much in advance


7 responses

Hi Mike,

I'd suggest installing nbconda to make it easier to switch environment in Jupyter. After doing that, you can simply open Jupyter in the environment you like straight from Anaconda Navigator.

I explain that in detail in my new book as well.


Thank you Andreas I will try that today! Also I ordered your new book I cant wait to read it (I loved your other two books), especially considering I can utilize my Python skills!

Thanks for all you do for the community

Thanks, Mike.

Jupyter drove me crazy in the beginning, with the trouble of switching environments or the inability to browse to files outside your home folder. It took me a while, but I learnt to love it in the end.

I find much of Python is like that. You will hate it in the beginning. Fight with it. Nearly burn it all down and move on. But once you get past the really annoying parts, you'll see the beauty of it.

What I've tried to do in the book is to guide you around all the annoying parts, and straight to the fun stuff.

Yes my experience with Python (now going on 2 years) has been much the same. Hated it at first but love it now.

I am firmly in the hating ZIpline w/ Jupyter phase right now HAHA but hopefully soon (with the help of your book) Ill move to the loving phase.

Hi Andreas, I followed the installation steps of zipline from your book. Zipline has been successfully installed. However, during the installation of nb_conda package in anaconda, I got the following error. Please help!

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:

  • nb_conda -> python[version='>=2.7,=3.6,=3.7,<3.8.0a0']

If python is on the left-most side of the chain, that's the version you've asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Your current python version
is (python=3.5). Note that conda will not change your python version to a different minor version
unless you explicitly specify that.

The following specifications were found to be incompatible with each other:

Package pip conflicts for:
python=3.5 -> pip
nb_conda -> python[version='>=3.6, pip
Package six conflicts for:
nb_conda -> notebook[version='>=4.3.1'] -> traitlets[version='>=4.2.1'] -> six
python=3.5 -> pip -> packaging -> six[version='>=1.9']
python=3.5 -> pip -> requests -> urllib3[version='>=1.21.1, cryptography[version='>=1.3.4'] -> six[version='>=1.4.1|>=1.5.2']
nb_conda -> notebook[version='>=4.3.1'] -> nbformat -> jsonschema[version='>=2.4,!=2.5.0'] -> six[version='>=1.11.0|>=1.5|>=1.9']
nb_conda -> notebook[version='>=4.3.1'] -> ipykernel -> ipython[version='>=5.0'] -> prompt_toolkit[version='>=1.0.4, six[version='>=1.4.1|>=1.5.2|>=1.9.0']
Package certifi conflicts for:
nb_conda -> python[version='>=3.6, pip -> requests -> certifi[version='>=2016.09|>=2017.4.17']
python=3.5 -> pip -> requests -> certifi[version='>=2016.09|>=2017.4.17']
Package wheel conflicts for:
nb_conda -> python[version='>=3.6, pip -> wheel
python=3.5 -> pip -> wheel
Package ipython_genutils conflicts for:
nb_conda -> notebook[version='>=4.3.1'] -> ipython_genutils
Package msgpack-python conflicts for:
python=3.5 -> pip -> cachecontrol -> msgpack-python
nb_conda -> python[version='>=3.6, pip -> cachecontrol -> msgpack-python
Package colorama conflicts for:
python=3.5 -> pip -> colorama
nb_conda -> python[version='>=3.6, pip -> colorama
nb_conda -> notebook[version='>=4.3.1'] -> ipykernel -> ipython[version='>=5.0'] -> jedi[version='>=0.10'] -> numpydoc -> sphinx -> colorama[version='>=0.3.5']
Package ipython conflicts for:
nb_conda -> notebook[version='>=4.3.1'] -> jupyter_client[version='>=5.2.0'] -> ipython[version='>=4.0|>=4.0.0|>=5.0']
Package ca-certificates conflicts for:
nb_conda -> python[version='>=3.6, openssl[version='>=1.1.1a, ca-certificates
python=3.5 -> pip -> requests -> urllib3[version='>=1.21.1, cryptography[version='>=1.3.4'] -> openssl[version='>=1.1.1a, ca-certificates
Package wincertstore conflicts for:
nb_conda -> notebook[version='>=4.3.1'] -> jinja2 -> setuptools -> wincertstore[version='>=0.2']
python=3.5 -> pip -> setuptools -> wincertstore[version='>=0.2']
Package setuptools conflicts for:
nb_conda -> notebook[version='>=4.3.1'] -> jinja2 -> setuptools
python=3.5 -> pip -> setuptools

Hi Roger,

Try following the advise from Robin Szeto here:

His solution is excellent, and I only wish I had thought of it first and used it in the book. :)


Dear Andreas,

It's working now! Thanks a lot!!